Haroeris Astrum (haroeris_astrum) wrote in diyhosting,
Haroeris Astrum
haroeris_astrum
diyhosting

Session Variables that Do Not Persist? Please Help

I had this conversation with FastHosts. Clearly they are either refusing to acknowledge my problem or I am being a bit thick. Please help me someone. I have included the conversation below, with my questions and responses in bold:

Here is an odd problem. When I run my ASP.Net on any server it works. When I run it on my fasthost server everything works except session variables do not persist across pages. Please resolve! It is probably an IIS setting that I can-not set programmatically.

Can you provide further information, including full replication steps on how we can see the fact that the session variables are being lost.

http://www.damn-them.com/login.aspx

username = tester@pcarney.me.uk
password = fish
then click "click here to submit details".

It sets the session variable "level" to 1 everywhere else but on fasthosts, which means that the page redirects to nothing I can use on your server. As I've said, It is MOST probably an IIS setting that I cannot change programmatically. Please resolve as this call should NOT be closed.


The domain is incorrectly configured, as the path to the site appears to be C:\Inetpub\wwwroot which is incorrect on our servers. This should be e:\domains\d\damn-them.com\user\htdocs

Please configure it correctly such that I might use session variables. It is after all a standard feature of ASP.

The problem is with your scripts - please re-configure them.

I do not use that anywhere in my scripts, compile or otherwise. Please give me access to the domain mapping so I might set it myself.

I have no idea unfortunately. I did take a look at the web.config file but couldn't see anything in there, I would advise you to contact the devel-opers of the software.

Here is the debug information:

Row handle is invalid.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.OleDb.OleDbException: Row handle is in-valid.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[OleDbException (0x80040e04): Row handle is invalid.]
System.Data.OleDb.OleDbDataReader.ProcessResults(Int32 hr) +63
System.Data.OleDb.OleDbDataReader.GetRowDataFromHandle() +105
System.Data.OleDb.OleDbDataReader.FindValueBinding(Int32 index) +34
System.Data.OleDb.OleDbDataReader.PeekValueBinding(Int32 index) +16
System.Data.OleDb.OleDbDataReader.GetValue(Int32 ordinal) +40
System.Data.OleDb.OleDbDataReader.get_Item(String name) +20
damn_them.CDataHandler.DoGetValue(String pQueryString, String pField-Name) in C:\Inetpub\wwwroot\CDataHandler.vb:90
damn_them.CRoutines.IsValidLogin(String ptxtRequestEmail, String ptxtPassword) in C:\Inetpub\wwwroot\CQueries.vb:26
damn_them.login.Button1_Click(Object sender, EventArgs e) in C:\Inetpub\wwwroot\login.aspx.vb:53
System.Web.UI.WebControls.Button.OnClick(EventArgs e) +108
Sys-tem.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +57
System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sour-ceControl, String eventArgument) +18
System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +33
System.Web.UI.Page.ProcessRequestMain() +1292

The path to your web folder is e:\domains\d\damn-them.com\user\htdocs. I would recommend you rebuild your application as this is clearly a scripting error.

C:\Inetpub\wwwroot\ is the path on the server it was build and it is pro-duced in line with the DLL and symbol debugging code. It does NOT pertain to physical files. I would like someone else to check my IIS settings please.

Unfortunately, IIS settings on the Shared Hosting servers are set up correctly, and cannot be changed. The path within your .Net Application will need to be updated if it is to be used on the Fasthosts servers.

I remain wholly unconvinced considering that the debug information re-ports symbolic debugging information at the time of compilation. Is there anyone there who actually knows about ASP.Net 1.1 and the necessary configuration for IIS?
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your IP address will be recorded 

  • 1 comment